Elevate Service Disruption
Incident Report for Cadmium
Postmortem

The service disruption was caused by a missing third-party dependency during a scaling event. As new servers scaled up to meet demand, the missing third-party dependency caused the application build to fail for the new servers. To address this issue, we are moving the third-party dependency into an internal repository to ensure availability. In the coming months we will be improving the Elevate hosting infrastructure to include the ability to fallback to the last known working version.

Posted Feb 07, 2024 - 16:26 EST

Resolved
The Incident has been resolved. We will share root cause analysis as soon as possible.
Posted Feb 07, 2024 - 10:32 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 07, 2024 - 10:01 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 07, 2024 - 09:18 EST
Investigating
We are currently investigating an issue causing service disruption to Elevate sites.
Posted Feb 07, 2024 - 08:36 EST
This incident affected: Elevate.