The issue has been resolved. We will share root cause analysis as soon as possible.
Posted Oct 21, 2025 - 09:01 EDT
Monitoring
Cadmium applications are becoming more stable as AWS services continue to recover. Our team is actively monitoring the situation and will make any necessary adjustments to maintain a stable environment.
Posted Oct 20, 2025 - 17:22 EDT
Update
Migration to an alternate region has been completed for our Mobile App. We are continuing to address issues that may be impacting Live Video Closed Captions, Elevate, and other systems.
Posted Oct 20, 2025 - 14:12 EDT
Update
We continue to implement disaster recovery operations to mitigate the AWS region-specific issues.
Posted Oct 20, 2025 - 12:14 EDT
Update
We continue to implement disaster recovery operations to mitigate the AWS region-specific issues.
Posted Oct 20, 2025 - 10:54 EDT
Identified
We continue to implement disaster recovery operations to mitigate the AWS region-specific issues.
Posted Oct 20, 2025 - 09:48 EDT
Investigating
Cadmium is aware of a service distruption to various services as a result of an AWS outage. We are monitoring the situation and preparing to failover to other regions.
Posted Oct 20, 2025 - 08:40 EDT
This incident affected: Eventscribe (Registration, Education Harvester, Website, Mobile App, Expo Harvester, myCadmium, Survey Magnet, Scorecard, Onsite), Elevate (Elevate, Conference365), and EthosCE, Warpwire.